Grafana Panel iframe fails to load properly only in incognito mode/window of Google Chrome

Hi All,

I noticed that when I use the embed code URL (my Grafana configuration allows anonymous access).

The following message appears in the area the iframe space only in Google Chrome Incognito window.

**If you're seeing this Grafana has failed to load its application files**

1. This could be caused by your reverse proxy settings.

2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath

3. If you have a local dev build make sure you build frontend using: yarn start, yarn start:hot, or yarn build

4. Sometimes restarting grafana-server can help

If I open the URL in a separate tab it loads fine with the specific panel.

There is no reverse proxy. There is no subpath. Grafana is deployed as grafana.mydomain.com.
Only Cloudflare CDN is used between the Grafana server and the website it is iframed.

Expected behaviour in: Google Chrome in normal mode, Firefox both modes, Edge both modes are working fine.

Bug found in: Google Chrome in incognito window (mode)

Version: Grafana v7.0.3 (00ee734baf)

Thank you in advance for your insights!

4 Likes

Have you found the solution, if so, will you share it here?