Grafana not using subpath, nginx

Hello,
I’m using Grafana behind a Nginx reverse proxy, and want to give Grafana the subpath “https:// mydomain (dot)com/grafana/”. But when i go to “https:// mydomain (dot)com/grafana/” i get redirected to “https:// mydomain (dot)com/login/” and get a 404 file not found error from Nginx. When i visit “https:// mydomain (dot)com/grafana/login/” i get the error “If you’re seeing this Grafana has failed to load its application files etc…” from Grafana.

My settings in the grafana.ini file under [server] is:
;root_url = %(protocol)s://%(domain)s:%(http_port)s/grafana/
;serve_from_sub_path = true

My Nginx configuration is:
server{
listen 443;
server_name mydomain(dot)com;
server_tokens off;
location /grafana/ {
proxy_pass http://localhost:3000/;
}
}

From what i can find online this should work, but it doesn’t
sorry for such awful looking example links, I’m not allow more than two links

solution found.
had not removed the “;” from the grafna.ini file. Thought only # were used for commenting out lines