Grafana Graph not showing the same bandwidth as PRTG

  • What Grafana version and what operating system are you using?

10.2 on Windows Server

  • What are you trying to achieve?

Time Series Graphs from PRTG

  • How are you trying to achieve it?

Using PRTG Plugin, on a windows cloud server with Grafana 10.2

  • What happened?

I have managed to get the time series graph, but the data rate (bandwidth) does not match what PRTG is showing.

  • What did you expect to happen?

Grafana time series graph to show the same bandwidth as PRTG

  • Can you copy/paste the configuration(s) that you are having problems with?
    response:"<?xml version=\"1.0\" encoding=\"UTF-8\"?>

    <histdata totalcount="180" listend="1">

    20.4.64.1402

    12/3/2023 6:05:11 AM

    <datetime_raw>45263.2536047569</datetime_raw>

    <value channel="Traffic IN (volume)" channelid="2">31 MB

    <value_raw channel="Traffic IN (volume)" channelid="2">32537436.0000</value_raw>

    <value channel="Traffic IN (speed)" channelid="2">4.34 Mbit/s

    <value_raw channel="Traffic IN (speed)" channelid="2">542742.8857</value_raw>

    <value channel="Traffic OUT (volume)" channelid="3">2.87 MB

    <value_raw channel="Traffic OUT (volume)" channelid="3">3012671.0000</value_raw>

    <value channel="Traffic OUT (speed)" channelid="3">0.40 Mbit/s

    <value_raw channel="Traffic OUT (speed)" channelid="3">50253.0609</value_raw>

    100 %

    <coverage_raw>0000010000</coverage_raw>

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

No Errors, i have set the “Unit” to Bits/sec (SI)

Welcome @ifinnan

Maybe prtg has been wrong all these years :scream::scream::scream:

Can you do a sample manual check for a specific time span data?

Hi, the PRTG data is correct for bandwidth, that has been verified.

I can get specific times spans, the graphs look exactly the same between PRTG and Grafana, its just the Axis is showing the incorrect data, i have adjusted the Unit but it doesnt make any difference, i think i need to do some math to convert it, but i dont see any options for that.

Thanks for your help

Actually they look identical just a bit more compressed in PRTG hence showing more time series in PRTG.

Hi,

Yes exactly, the graphs are the same, but the actual values they show are not.

PRTG shows the value in Mbit/s and Grafana is kb/s

I have tried changing the unit in Grafana but it just changes the graphs to Mbit/s but the graph changes automatically to Gb/s

It seems i have to do some calculation setting for *8 or /8 to get the correct value but i dont see any option for that.
BOTH

1 Like

Standard Options has mb/s

Thanks,
This is the option when i select it it changes the bandwidth to Gib/s, the router i am monitoring is constatly using 4.5 Mbps, and the PRTG graph displays that amount, but not Grafana.

standard