Grafana Cloud Tempo + Zipkin

Hi All,
I am trying to send span data using curl (zipkin) to Grafana Clound Tempo as per the docs here (Pushing Spans with HTTP | Grafana Labs).
This is the curl

curl -X POST https://<MY-ID>:<MY-API-KEY>@tempo-xx-xxxxxxx.grafana.net/ -H 'Content-Type: application/json' -d '[{
 "id": "1234",
 "traceId": "0123456789abcdef",
 "timestamp": 1608239395286533,
 "duration": 100000,
 "name": "span from bash!",
  "localEndpoint": {
    "serviceName": "shell script"
  }
}]'

I do get a “OK” response from the above command but when search for the traceID in grafana.net , I dont see it.

Is the zipkin format not enabled in tempo cloud version or there is something wrong with the data or the url? I have redacted the url partially

Why I am trying to do a curl is basically I want to send the span data via spring cloud sleuth (zipkin/brave) which can directly send it to a zipkin server instead of running agents.

Thank you.

Hi hkdoley,

While Tempo itself can receive multiple formats, Grafana Cloud Traces only accepts OTLP GRPC.
The docs about pushing spans are about self-hosted Tempo. I get this is pretty confusing, we’ll work on clarifying the difference with Tempo in Grafana Cloud.

In your case, if your application emits Zipkin, you will have to run an instance of the Grafana Agent or the OpenTelemetry Collector with the Zipkin receiver enabled.

Hi Koenrad,
Thanks for the clarification!
Will push them via an agent.

Yep no worries about the docs.
I am loving the fact that I can have all 3 aspects of observability in one single system!
Great work guys.

1 Like