Grafana 7, Alerting issue, error:"tsdb.HandleRequest() ... unsupported protocol scheme "influxdb"

Hi, I have upgrade to 7 in docker. Alerts are not working anymore. I get following error messages and notifiction emails (if exception error or timeout - alert). Does anybody know whats wrong with my config? Graph itself works.I didn’t see issues earlier.

I’m using InfuxDb (working) and notification by mail. Also working otherwise I wouldn’t see lot’s of mails. But something is wrong.

Thank you!

t=2020-05-31T18:39:10+0000 lvl=eror msg=“Alert Rule Result Error” logger=alerting.evalContext ruleId=3 name=“CPU Load alert” error=“tsdb.HandleRequest() error Get “influxdb:8086?db=telegraf&epoch=s&q=SELECT+mean%28%22ssCpuIdle%22%29+%2A-1+%2B100+FROM+%22snmp.SYNO%22+WHERE+%22agent_host%22+%3D+%27192.168.0.28%27+AND+time+%3E+now%28%29±+5m+GROUP+BY+time%28200ms%29%2C+%22laNames%22”: unsupported protocol scheme “influxdb”” changing state to=alerting

Hi all, I assume this is a bug … I think I found the issue. I have configured the datasource Influxdb without leading “http:” … this works to display the graph but alerts are failing. Will check a while and open a bug-report (sure, my fault, but it could help others).

2 Likes

thanks for the hint. The case is, you are allowed to save a datasource without leading “http://” and everything will be working fine, until you decide to create alerts. Instead of error message, there will be “tsdb.HandleRequest()”

1 Like

solved for me too… adding the http:// to the begin solved it completely

Wow, this just bit me as well. Definitely a bug. If not a code bug, then a UI or Documentation bug. When setting up the datasource, there is NO indication one way or another that a protocol would need to be specified.