Grafana 10.3.3 - pushover - hide annotations in message

I recently upgraded an old version of grafana on my local raspberry pi.
To me the new alerting service seems to be quite “challenging” (personally the old version was more intuitive)
The alerts i’m using are pushover messages when a certain treshold ow my power usage is reached (linked to a graph)

However i’m running into 2 problems (with the alerts that were migrated from the old 8.x version)

  • first the message itself:
    — how to disable the “General Alerting” and ruile_uid in the title of the pushover message?
    — how to hide/disable the “annotations”? This used to look like links, but now it’s text?
    — how to choose what labels to send? (in my case hide the grafana folder and rule_uid)
  • second the value: This works on the “Firing” message, but on the resolved message it says [no value]. I also send “verbruik” (defined as {{index $values “B0” }} ) and this seems to send the “old” value that triggered the alert and not the current one?

Does anyone have an idea?

I found some solutions. For others that may have the same problem, here is how i “solved” it:

  • the message itself: i made a custom notification template based on the default one
  • the resolved with missing series: you cannot put the value in a label, you should put it in an annotation. If you put it in label and the value changes, the alert will have changed and does not exist anymore (so hence the “missing series”)