Fresh grafana install asks for http auth,

I installed latest stable grafana on a debian buster. After setting it up and login in as user admin, setting the admin password i am greeted with an http auth form from my browser, which will not accept any password. Canceling out of it will let me use grafana but it will show an “unexpected error” and a red “!” saying "undefined is not an object (evaluating

i tried to set
enabled = false

But it has no effect.

I’m having the same issue. Have you found a solution?

Ok. So to better detail what I have done. I followed this tutorial to step up InfluxDB and Grafana. I got to the point were I was adding a datasource in grafana when I got this error.
After many experiments I think that this error is caused by entering the wrong credentials or ip address the first time I tried to create the datasource. I speculate that this might have cause some error on the internal grafana database that can’t be corrected by changing the values on grafana datasource page.
After deleting the datasource and creating a new one with the same values the error didn’t show up anymore.