Fixing Time Axis for PostgreSQL Data Upload into Graph

Using Grafana v.8.4.3 with Windows 10, I am looking for an assist with uploading my data from my localized PostgreSQL database to Grafana. I am able to sync them up correctly, but am falling on my face with the time variable for the x-axis. The first column in my table follows the following format, ‘yyyy/mm/dd hh:mm:ss.msmsms’ I always end up with “Data is missing a time field”. timestamp is the name of the first column of the sql table. busload is a random column that is typically a non-zero numerical value.

have you tried using the convert field type transformation to forcibly change your timestamp with a time data type?

I haven’t. Just tried but my timestamp is in the following format YYYY/MM/DD hh:mm:ss.(3 decimal places for milliseconds).

I’m not sure how to account for the milliseconds.

Turns out that my timestamp column was type “Text” in the postgreSQL database. I converted it to “timestamp with time zone” and that fixed the issue.

1 Like