Error with prometheus in tutorial


I’m fresh of the boat when it comes to Grafana, so when I went through with the turorial I get an error on the prometheus when running this in Git BASH .

$ docker-compose up -d
tutorial-environment_grafana_1 is up-to-date
tutorial-environment_db_1 is up-to-date
Starting tutorial-environment_prometheus_1 ...
tutorial-environment_loki_1 is up-to-date
tutorial-environment_promtail_1 is up-to-date
Starting tutorial-environment_prometheus_1 ... error

ERROR: for tutorial-environment_prometheus_1  Cannot start service prometheus: error while creating mount source path '/run/desktop/mnt/host/c/Users/H▒kon/tutorial-environment/prometheus': mkdir /run/desktop/mnt/host/c: file exists

ERROR: for prometheus  Cannot start service prometheus: error while creating mount source path '/run/desktop/mnt/host/c/Users/H▒kon/tutorial-environment/prometheus': mkdir /run/desktop/mnt/host/c: file exists
Encountered errors while bringing up the project.

When checking how everything went, which is the next step in the tutorial, I get this:

$ docker-compose ps
              Name                             Command                State             Ports
tutorial-environment_app_1          /bin/sh -c /app http://db  ...   Up>80/tcp
tutorial-environment_db_1           /db                              Up>80/tcp
tutorial-environment_grafana_1      /                          Up>3000/tcp
tutorial-environment_loki_1         /usr/bin/loki -config.file ...   Up>3100/tcp
tutorial-environment_prometheus_1   /bin/prometheus --config.f ...   Exit 128   
tutorial-environment_promtail_1     /usr/bin/promtail -config. ...   Up   

And this was after the first time running. I tried running the codes again, tried stopping the services (as the tutorial recommend trying), as well as deleting the files downloaded in docker and running all the code again (same thing happens). This causes an error HTTP Error Bad Gateway in step 4 of the Grafana fundamentals.

Does anyone have any ideas on how to fix this. As stated, I’m completely unexperienced here, so it’s probably something obvious. Thanks for your help in advance.

where is the tutorial


Just to make sure, does your username have a special character (it may cause issues).

Good Luck

Here: Grafana fundamentals | Grafana Labs

Well yes, it does have an å in it. I’ll try an change my username, and if that doesn’t break everything, I’ll redo the code.