Enabling Grafana 8 alerting

Grafana: 8.3.4
Amazon Linux 2.
Also have prometheus installed.

My problem is I follow the directions here: Opt-in to Grafana alerting | Grafana Labs

But can not enable Grafana 8 alerting. I used the rpm to install so I do not have a custom.ini. However in my grafana.ini that it’s pointed at has.

Alerting

[alerting]

;enabled = false

and under
[unified_alerting]
;enabled = true

So according to the docs I should be enabled. But when i go under alerts I see a message of “Try out Grafana 8 alerting!.. You are using legacy Grafana alerting…”

so what gives how do i get the new alerting to work?

remove the semicolon that starts the line. Restart Grafana, and see if Unified Alerting is working

[unified_alerting]
enabled = true

ugh. so am i a moron? I didn’t realize that a “;” would comment out the line as the entire file is littered with semi-colons. in fact every line single line in the config file that is not a “#” comment has a “;” in front of it…

but taking those semi-colons out worked, thx.