Embed error - Panel with id not found

After updating to version 6.2, Grafana stopped displaying charts embedded on another page.
Wordrpess, which I use, adds “amp;” or “#038” to links in the iframe and the query is not recognizable by the Grafana. Earlier versions of such a problem did not have.
Any idea how to fix it?

Wordrpess link:

working link:

we are opening the file:
in the server section we add
proxy_hide_header X-Frame-Options;
we restart nginx. From now everything should work.

Please read the upgrade notes. There’s a new setting introduced.

Adding to this support thread as the error is the same. Situation somewhat different.

I tried to embed from orgId=2 this ends up with an error in the systemctl status grafana-server that Dashboard not found in orgId=1

Nov 14 16:03:46 msg=“Request Completed” logger=context userId=0 orgId=1 uname= method=GET path=/api/dashboards/uid/jRrsue7Wz status=404 referer=“http://x.x.x.x:3000/d-solo/jRrsue7Wz/DCE?orgId=2&from=1573725473666&to=1573747073667&var-host=All&panelId=6”

Nov 14 16:03:49 lvl=eror msg=“Dashboard not found” logger=context userId=0 orgId=1 uname= error=“Dashboard not found”

Verified by moving dashboard to orgId=1 then embedding worked.

Seems like it should also work when orgId=2

Is there something that is needed in url to authenticate?