Different behavior between table and graph

Hello everybody,
I’m a happy Grafana user but in these days I changed my application setup and now I can’t figure out what is going wrong.
I made a dashboard with few graphs and few tables, but the time representation looks different: the time in the table is shown correctly (the timezone UTC+2 is right, got from browser settings) but in the graph looks that the time values are shown in UTC, while the filter limits correctly the last 6 hours.

2018-04-09%2019_02_43)

Did I misconfigured anything?

  • I’m using Grafana 5.04 on Linux system

  • The database is MySQL

  • All the times are stored in the database in UTC format

  • The select query I use to populate the graph is
    SELECT
    UNIX_TIMESTAMP(TimeTemperature) as time_sec,
    Temperature as value, ‘Sensore_Filtro’ as metric
    FROM TempCheck WHERE $__timeFilter(TimeTemperature) AND Sensor=2
    ORDER BY TimeTemperature ASC

  • I already tried to replace UNIX_TIMESTAMP(TimeTemperature) with UNIX_TIMESTAMP(CONVERT_TZ(OraRilevamento,’+00:00’,’+02:00’)), the times now are displayed correctly, 2018-04-09%2019_23_36-Grafana%20-%20Aquarium but the graph has a big hole at the beginning (seems the “last 6 hour” filter is not interpreted correctly) and also the notifications are not working at all :frowning_face:

I hope you can help me! Thank you in advance! :grinning:

I solved by changing the system clock and I set it back to UTC.
These solved all the graph issue and didn’t change anything in the table values. I know timezone issues are quite common, but at least will be everything easy if both graph and table had the same values.