Can't get rid of 401: unauthorized error on iphone

I have Grafana working beautifully on my chrome browser, but when trying to view it on my Home Assistant via my iphone, it does not load. I get nothing but 401: unauthorized error.
I added all of the extra bits into my configuration file, set my network to 3000, and reset my cache multiple times with no luck.
I believe the recent update made it worse somehow? Please help, I dont know where to go from here and I really want to use this for my Home Assistant.

Hello :wave: and welcome to the forum, @ninamarie8253

Can you help us understand this issue a little better?

Where is Grafana running right now? On a local machine? On a server accessible over the internet? On Grafana Cloud?

What URL are you typing into your phone? Just trying to understand your network architecture a little better…

Also, in the meantime you might want to repost this in the Home Assistant forum. There are loads of Grafana related topics over there…

Thank you SO MUCH for responding!!
So I am running Grafana via Home Assistant Core through Oracle VM on my PC.
I am using this grafana link to try to access my dashboards via iframe, it works great on chrome, but I just get 401: unauthorized error on my iphone:

https://myhomeassistant.duckdns.org/api/hassio_ingress/79cXia4syvD2xJ-nvGEaksYvWaqqPAsz0Jt0w4-j4wA/d/YHrlEBJ7k/stats?orgId=1&from=1642626328463&to=1642647928463

I have set the port as 3000, Ive tried the ip address of my home assistant with the :3000 at the end of it, I’ve tried https, http, etc etc. Here is my grafana configuration panel:

I did also post this in Home Assistant, but no responses yet, even on reddit and discord:
https://community.home-assistant.io/t/grafana-401-unauthorized-error-on-iphone-only/381885

image

Any ideas @mattabrams?

@ninamarie8253 It sounds like you have searched & posted a lot on this topic already, but just in case this one slipped by, here is a fix for what ** sounds ** like a similar issue to the one you described: Tutorial to fix 401: Unauthorised Error with Grafana for mobile devices - Community Guides - Home Assistant Community

1 Like

Unfortunately none of that works. Do you have grafana working on the iphone? On any connection, local or not? Because it seems like an impossibility…