Can't connect to MySQL datasource since switch to "--require_secure_transport=ON" mode

Hi Grafana Community,

some time ago our MySQL database changed its configuration and enabled “–require_secure_transport=ON” and we connect using TLS with our SQL tooling (for me IntelliJ).

Error message I get:
“logger=tsdb.mysql t=2023-01-16T10:32:40.287979533+01:00 level=error msg=“Query error” error=“Error 3159: Connections using insecure transport are prohibited while --require_secure_transport=ON.””

I can connect using IntelliJ just by enabling TLS/SSL checkox. No certificate or any other file is needed.

I tried the checkboxes in various constellations but none were successful. I didn’t add any information in the appearing boxes as this shouldn’t be necessary.

Can you please help me how I can configure this or is this a bug?

Thank you in advance

Using v9.3.2 (21c1d14e916)

Hi @otakun85,

Welcome to the :grafana: community support forums !!

We are excited that you joined our OSS community. Please read about some of the FAQs in the community :slight_smile:

I understand that your MySQL server is now secured by enabling this configuration parameter:

require_secure_transport=ON

Is the SSL configured to work with the remote host?

Might be good to check this link:

Let us know if this helps.

Hello and thank you for the quick reply.

If I read the content of the link correctly than this describes how I can setup in general a mysql server and client to connect from with TLS.

Yet in my situation the server is already setup.

I configured following in MySQL Workbench or IntelliJ and it just works:
Host
username and password
(Use SSL if available, default setting)

So I’m wondering why it’s not working in Grafana data source setting?