Blank web page but server is running


Just installed Grafana. Seems OK as server is running but when I open webpage all I get is a blank page my URL shows as, the IP is the device IP on my network.

Have unistalled and installed a few time but same result. This is a Debian install onto a Raspberry Pi running Raspbian.

Any ideas to help me ?


Hi, I am seeing the same kind of issue. I am running on a Raspberry pi 3 and fresh install of Debian Stretch.
I used packages installation, and the database seems to be starting OK, but I get no response from localhost:3000 other than the tab show the Grafana logo, so there is a little life there, but no GUI, so I am reaching out to see if I can find some things to try.

I ran into some pre-req issues and had attempted the grafana install (failed due rto pre-reqs), but I located and installed them all and the Grafana-data finally completed without error.
55 wget http ://
74 sudo dpkg -i grafana-data_2.6.0+dfsg-3_all.deb

I ran into the same issue with pre-reqs when installing Grafana…
77 wget http ://
89 sudo dpkg -i grafana_2.6.0+dfsg-3_armhf.deb

Once the pre-reqs were installed the Grafana packages installed OK, but I get a blank page when attempting to look at localhost:3000.

Here is output of the status command…

pi@reporterpi:/var/log/grafana $ sudo systemctl daemon-reload
pi@reporterpi:/var/log/grafana $ sudo systemctl start grafana-server
pi@reporterpi:/var/log/grafana $ sudo systemctl status grafana-server
● grafana.service - Starts and stops a single grafana instance on this system
Loaded: loaded (/lib/systemd/system/grafana.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2018-01-14 01:47:27 EST; 15h ago
Main PID: 405 (grafana)
CGroup: /system.slice/grafana.service
└─405 /usr/sbin/grafana --config=/etc/grafana/grafana.ini cfg:default.paths.logs=/var/log/grafana

Jan 14 01:47:29 reporterpi grafana[405]: [0]:
Jan 14 01:47:29 reporterpi grafana[405]: [1]: default.paths.logs=/var/log/grafana
Jan 14 01:47:29 reporterpi grafana[405]: Paths:
Jan 14 01:47:29 reporterpi grafana[405]: home: /usr/share/grafana
Jan 14 01:47:29 reporterpi grafana[405]: data: /var/lib/grafana
Jan 14 01:47:29 reporterpi grafana[405]: logs: /var/log/grafana
Jan 14 01:47:29 reporterpi grafana[405]: 2018/01/14 01:47:29 [I] Database: sqlite3
Jan 14 01:47:29 reporterpi grafana[405]: 2018/01/14 01:47:29 [I] Migrator: Starting DB migration
Jan 14 01:47:30 reporterpi grafana[405]: 2018/01/14 01:47:30 [I] Listen:
Jan 14 17:00:18 reporterpi grafana[405]: 2018/01/14 17:00:18 [I] Completed [::1] - “GET / HTTP/1.1” 302 Found 29 bytes in 16141us

Any help or suggestions are appreciated !

This is because the Debian supplied package is massively old (2.6) and doesn’t work (and shouldn’t have been included IMHO).

If you look at at the browser’s developer console, you’ll probably see errors like:

Uncaught TypeError: Cannot read property 'indexOf' of undefined at draganddrop.js

As per issue Installation issue in Ubuntu 17.04 + Blank screen), use the steps from the official documentation to install Grafana:

I’ve got the same problem. i have a blank page and here’s what’ve got on my console

what shall i do ??