AWS-Timestream Graphs worked before 7.5 update, and now multiple queries cannot be graphed together on a single graph

  • What Grafana version and what operating system are you using?
    I am using the Online Grafana version 7.5.6
  • What are you trying to achieve?
    Fix the graphs, which previously worked before the 7.5.6 update. Multiple queries will not graph on a single graph, and will only show the first query.
  • How are you trying to achieve it?
    I am using Timestream as my data source and I am sending data to the database using a python script. I then use a query to request the data and it graphs to the panel. I use multiple query requests and before the 7.5 update they all showed up on the graphs. The data is definitely being sent to the database because using a timestream query utility, I can see that my data is being properly inserted.
  • What happened?
    After the 7.5 update the graphs would only graph the first query and the rest of the queries would not show up on the dashboard. If I switched the orientation of the queries the query directly at the top would always be the one graphed, the other queries would not even be listed in the legend.
  • What did you expect to happen?
    I expected the graph to show all 5 queries in the graph and on the legend.
  • Can you copy/paste the configuration(s) that you are having problems with?
    I am using the online Grafana version, and i did not have to do much configuration
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    I have not seen any errors related to this.
  • Did you follow any online instructions? If so, what is the URL?