413 error when writing data to InfluxDB

Hi there!
Mostly related to InfluxDB issue, but maybe you can help me

ERRO[0202] InfluxDB: Couldn't write stats error="<html>\r\n<head><title>413 Request Entity Too Large</title></head>\r\n<body>\r\n<center><h1>413 Request Entity Too Large</h1></center>\r\n<hr><center>nginx/1.15.6</center>\r\n</body>\r\n</html>\r\n"

Receiving this during test execution. And some data is not been written to InfluxDB
Do you know any solutions of this?

Looking at the InfluxDB docs, you should be able to adjust the max-body-size option to fix this: Configuring InfluxDB OSS | InfluxDB OSS 1.7 Documentation (but considering this issue, that may not always work)

I think the only thing you can adjust from the k6 side is the to use the K6_INFLUXDB_PAYLOAD_SIZE, I’m not sure that one affects HTTP connections to InfluxDB, it seems like it’s meant only for UDP connections.

1 Like