You appear to have no compatible data sources grafana

Hello

On grafana 9.0.5

image

Suddenly getting this message and I am unable to create alerts. I have mssql, mysl, postgres etc data sources.

Any idea?

Thanks

The issue was that my default data source was infinity. Once I changed it to mssql it works.

1 Like

Yea unfortunately infinity doest support alerts and expression. But something coming in soon.

Excited about the upcoming V1.0.0 of infinity.

1 Like

I too just noticed that (after upgrading to 9.0.5) I was suddenly getting the same message and was unable to create alerts. I changed my default datasource and it works, but this seems like a bug, i.e for those of that may want to create alerts for many datasources, the message is misleading. It should say something about the default datasource.

1 Like