Unit: display only the prefix symbol (k, M, T,...)

I’m using the latest version (9.1.7).

Am I crazy or there is no way to display only the prefix symbol such μ, m, k, M, G, T,…etc

None of the available options seems to do that.

as example… I’m looking for a way to display value of 1 000 000 as 1 M in the panel, etc.

Perhaps one would look for it in here:
Standard option → Unit: Misc > Prefix Symbol

Welcome to the Grafana forum.

Did you try this?

BEFORE:
Standard option → Unit → Misc → Number:

AFTER:
Standard option → Unit → Misc → Short:

Yep I did and this is what’s being displayed.

While it’s supposed to display 7.49 P
Quadr for Quadrilion? It works, but that’s not really scientific.

image

Issue created: Standard options: unit: SI prefix needed · Issue #78022 · grafana/grafana · GitHub
PR opened: Unit: Add SI prefix for empty unit by raymalt · Pull Request #78023 · grafana/grafana · GitHub

1 Like

FYI - This feature has now been merged and will be part of a future release. The unit option will be named “SI short”.

1 Like