Unable to swap to legacy alerting on Linux when from 8.4.4 to +9.0

Hi, so I’m currently running Grafana 8.4.4 on a Linux machine, and I’ve tried to upgrade to the most recent version of 9.0

The issue I’m having is staying on legacy alerting, as there are lots of alert currently that doesn’t translate over to unified alerting that well. I usually don’t have problem configuring this in the config file on other machines I have that also run Grafana 9.0.

The config file doesn’t update the tags to with the newest tags either when I upgrade from 8.4.4, and I’ve also tried to copy paste the default config file from the Grafana github. So instead I’ve tried to copy paste the [unified alerting] in the config file, but when I put enabled = true it gives the following error when I restart the grafana service:

Unknown lvalue 'ProtectClock' in section 'Service'
Unknown lvalue 'ProtectHostname' in section 'Service'
Unknown lvalue 'ProtectKernelLogs' in section 'Service'
Unknown lvalue 'ProtectProc' in section 'Service'

I’ve prevously solved this following the guide on the github thread here:

But this does no longer fix it. So does anyone maybe have the same issue and perhaps a workaround for this? :slight_smile:

You’ll want to enable unified alerting and disable legacy alerting:

[alerting]
enabled = false

[unified_alerting]
enabled = true

I already have done that. I’m looking to go the other way around actually, so enable legacy alerting and disable unified alerting.

[alerting]
enabled = true

[unified_alerting]
enabled = false

But I receive a 502 Bad Gateway when I then try to access the site. And when I check grafana-server status I receive the following:

Unknown lvalue 'ProtectClock' in section 'Service'
Unknown lvalue 'ProtectHostname' in section 'Service'
Unknown lvalue 'ProtectKernelLogs' in section 'Service'
Unknown lvalue 'ProtectProc' in section 'Service'