TLS verification

I’m new to the k6 world, and I’m trying to make some stress test to a local website. I use minikube to run k8 and my website is writen in drupal. I’m having some problems with the TLS verification. I already tried the insecureSkipTLSVerify option, already tried the K6_INSECURE_SKIP_TLS_VERIFY env, also tried the --insecure-skip-tls-verify, nothing seems to work. I wrote a simple code just to start the stress test and see if everything was working, here is the code:

import { browser } from 'k6/experimental/browser';
import { sleep } from 'k6'

export const options = {
  scenarios: {
    ui: {
      executor: 'shared-iterations',
      options: {
        browser: {
          type: 'chromium',
        },
      },
    },
  },
  insecureSkipTLSVerify: true
}

export default async function () {
  const page = browser.newPage();

  try {
    page.setExtraHTTPHeaders({
      'sec-ch-ua': '"Chromium";v="94", "Google Chrome";v="94", ";Not A Brand";v="99"',
      'accept-encoding': 'gzip, deflate, br',
      'accept-language': 'en-GB,en;q=0.9',
    });
    await page.goto('http://drupal.local');
    sleep(2)
    page.screenshot({ path: 'screenshots/screenshot.png' });
  } finally {
    page.close();
  }
}

Here is the screenshot:

Hi @phenriquelongo , welcome to the community forum!

This is because insecureSkipTLSVerify does not affect the browser.
Could you try to run k6 with the K6_BROWSER_ARGS="ignore-certificate-errors" environment variable?

3 Likes

It worked!!! You are a life saver, thank you so much!

2 Likes