Templating Query doesnt return any values


Am having an issue with templating query where for some reason, it does not show any data. Query is pretty simple and when I point it to a different data source, it works just fine. Am using ElasticSearch Datasource with Grafana 4.5.2

{“find”: “terms”, “field”: “beat.hostname”}

Here are a few test cases I tried and results I got

Grafana 4.5.2 & ES 5.6.1 --> doesnt populate any data, but when I create a table and sort data based on hostname, totally works fine.

Grafana 4.5.2 & ES 5.4.0 --> everything works just fine

Are there any known issues or limitations with the combination am using that can cause this? Any possible options I can try, to understand why this happening and a possible solution.

I really appreciate any help and in-sights into this and let me know if any additional information is needed



Sorry just noticed that beat.hostname is not a keyword on ES and as a result I was facing this issue. Modified that to use keyword variable and it worked right away.

Hi Vish,
what would be the variable name and where do i search that cause i am not able to find anything in ES… i can see its just hostname , can you please help me with it?