Stop The Cooldown?

Is there a way to tell K6 to stop making requests without a cooldown?

Hi @pt_tegria,

Can you expand on what you mean? k6 doesn’t really have a concept of a cooldown anywhere so my only guess will be that you are talking about timeout :person_shrugging:

Also maybe it’s better to tells us what you want to accomplish in the first place and we can come up with how that can happen together.

See text in red box in screenshot below. Seems like K6 is adding a 30s VU rampdown from my last stage of 200 VUs. It’s not specified in the stages I put into the options.

Hello Pt_tegria,

If you’re using stages, the test is using the “Ramping VUs” scenario under the hood. You can configure the rampdown time with the gracefulRampdown option:

For other scenarios, configure the rampdown with Graceful stop.