SMTP configuration with Amazon SES

Has anyone ever been able to use Amazon SES as an SMTP server and pass AWS generated SMTP credentials into the grafana config.ini?

I’ve tried it so many different ways but it just isn’t working for me. I thought it could take a generic SMTP server and with user/pass just start sending alert notifications on a configured alert channel.

Provisioned channel config:

notifiers:
  - name: email-channel-1
    type: email
    uid: emailnotifier1
    org_id: 1
    is_default: true
    send_reminder: false
    disable_resolve_message: false
    # See `Supported Settings` section for settings supported for each
    # alert notification type.
    settings:
      uploadImage: true
      singleEmail: true
      addresses: asdf@myrealemailaddress.com;asdf2@otherrealemailaddress.com

config.ini additions:

[smtp]
# If the password contains # or ; you have to wrap it with trippel quotes. Ex “”"#password;"""

enabled = true
host = email-smtp.us-west-2.amazonaws.com:465

# password do not contain semicolon or hash symbol
# does it expect them base64 encoded or something?

user = <got from AWS SMTP username>
password = <got from AWS SMTP password>

;skip_verify = true
from_address = myverifiedemail@mydomain.com
from_name = Grafana
1 Like

I am facing similar issue. Any documentation for steps to configure email notification through AWS SES ?

Any solutions? I have the same problem here.

You need to create SMTP user credentials for Amazon SES - the IAM user credentials will not work (Obtaining your Amazon SES SMTP credentials - Amazon Simple Email Service Classic).

Then use port 587 and MandatoryStartTLS.