SMTP configuration with Amazon SES

Has anyone ever been able to use Amazon SES as an SMTP server and pass AWS generated SMTP credentials into the grafana config.ini?

I’ve tried it so many different ways but it just isn’t working for me. I thought it could take a generic SMTP server and with user/pass just start sending alert notifications on a configured alert channel.

Provisioned channel config:

  - name: email-channel-1
    type: email
    uid: emailnotifier1
    org_id: 1
    is_default: true
    send_reminder: false
    disable_resolve_message: false
    # See `Supported Settings` section for settings supported for each
    # alert notification type.
      uploadImage: true
      singleEmail: true

config.ini additions:

# If the password contains # or ; you have to wrap it with trippel quotes. Ex “”"#password;"""

enabled = true
host =

# password do not contain semicolon or hash symbol
# does it expect them base64 encoded or something?

user = <got from AWS SMTP username>
password = <got from AWS SMTP password>

;skip_verify = true
from_address =
from_name = Grafana
1 Like

I am facing similar issue. Any documentation for steps to configure email notification through AWS SES ?

Any solutions? I have the same problem here.

You need to create SMTP user credentials for Amazon SES - the IAM user credentials will not work (Obtaining your Amazon SES SMTP credentials - Amazon Simple Email Service Classic).

Then use port 587 and MandatoryStartTLS.


I saw your config and it helped resolve mine. Because of the port number.

I also verified my domain in SES. Otherwise it doesn’t let you send any emails.

Other than that you can also check if your files match grafana’s config in the UI settings.

Facing a similar issue.

enabled = true
from_address =
from_name = myname
host =
password = validpassword
startTLS_policy = MandatoryStartTLS
user = validuser

error “failed to send notification to email addresses: ***: gomail: could not send email 1: read tcp> i/o timeout”

Connectivity seems fine. From another pod in the cluster:

/ # nc -vz 587 ( open
/ # telnet 587
Connected to
220 ESMTP SimpleEmailService-d-86SNBJ70N AgPcnOCZxSp2DRD4eHDu

I also use the same credentials and from address other apps on the same network and they work fine.

Tried port 25 and 587, with and without MandatoryStartTLS.

How can I diagnose this further?

I tested a local SMTP server and TLS is functional. I also tested the same connection parameters from another app inside the cluster and AWS SES works properly.

I don’t know why I keep getting i/o error. I see many questions online about gomail and SES failing because of the timeout not being high enough? I don’t see a way to configure the smtp timeout via Grafana config?