Release Notes v4.6.x


#1

Grafana v4.6 brings many enhancements to Annotations, Cloudwatch & Prometheus. It also adds support for Postgres as metric & table data source!

Annotations

You can now add annotation events and regions right from the graph panel! Just hold CTRL/CMD + click or drag region to open the Add Annotation view. The
Annotations documentation is updated to include details on this new exciting feature.

Cloudwatch

Cloudwatch now supports alerting. Setup alert rules for any Cloudwatch metric!

cloudwatch_alerting

Postgres

Grafana v4.6 now ships with a built-in datasource plugin for Postgres.

Prometheus

New enhancements include support for instant queries and improvements to query editor in the form of autocomplete for label names and label values.
This makes exploring and filtering Prometheus data much easier.

4.6.4 (2018-08-29)

Important fix for LDAP & OAuth login vulnerability

See security announcement for details.

4.6.3 (2017-12-14)

Fixes

  • Gzip: Fixes bug gravatar images when gzip was enabled #5952
  • Alert list: Now shows alert state changes even after adding manual annotations on dashboard #9951
  • Alerting: Fixes bug where rules evaluated as firing when all conditions was false and using OR operator. #9318
  • Cloudwatch: CloudWatch no longer display metrics’ default alias #10151, thx @mtanda

4.6.2 (2017-11-16)

Important

  • Prometheus: Fixes bug with new prometheus alerts in Grafana. Make sure to download this version if your using Prometheus for alerting. More details in the issue. #9777

Fixes

  • Color picker: Bug after using textbox input field to change/paste color string #9769
  • Cloudwatch: Fix for cloudwatch templating query ec2_instance_attribute #9667, thanks @mtanda
  • Heatmap: Fixed tooltip for “time series buckets” mode #9332
  • InfluxDB: Fixed query editor issue when using > or < operators in WHERE clause #9871

4.6.1 (2017-11-01)

  • Singlestat: Lost thresholds when using save dashboard as #9681
  • Graph: Fix for series override color picker #9715
  • Go: build using golang 1.9.2 #9713
  • Plugins: Fixed problem with loading plugin js files behind auth proxy #9509
  • Graphite: Annotation tooltip should render empty string when undefined #9707

4.6.0-stable (2017-10-26)

Fixes

  • Alerting: Viewer can no longer pause alert rules #9640
  • Playlist: Bug where playlist controls was missing #9639
  • Firefox: Creating region annotations now work in firefox #9638

4.6.0-beta3 (2017-10-23)

  • Prometheus: Fix for browser crash for short time ranges. #9575
  • Heatmap: Fix for y-axis not showing. #9576
  • Save to file: Fix for save to file in export modal. #9586
  • Postgres: modify group by time macro so it can be used in select clause #9527, thanks @svenklemm

4.6.0-beta2 (2017-10-17)

Fixes

  • ColorPicker: Fix for color picker not showing #9549
  • Alerting: Fix for broken test rule button in alert tab #9539
  • Cloudwatch: Provide error message when failing to add cloudwatch datasource #9534, thx @mtanda
  • Cloudwatch: Fix unused period parameter #9536, thx @mtanda
  • CSV Export: Fix for broken CSV export #9525
  • Text panel: Fix for issue with break lines in Firefox #9491
  • Annotations: Fix for issue saving annotation event in MySQL DB #9550, thanks @krise3k

v4.6.0-beta1

New Features

  • GCS: Adds support for Google Cloud Storage #8370 thx @chuhlomin
  • Prometheus: Adds /metrics endpoint for exposing Grafana metrics. #9187
  • Graph: Add support for local formating in axis. #1395, thx @m0nhawk
  • Jaeger: Add support for open tracing using jaeger in Grafana. #9213
  • Unit types: New date & time unit types added, useful in singlestat to show dates & times. #3678, #6710, #2764
  • CLI: Make it possible to install plugins from any url #5873
  • Prometheus: Add support for instant queries #5765, thx @mtanda
  • Cloudwatch: Add support for alerting using the cloudwatch datasource #8050, thx @mtanda
  • Pagerduty: Include triggering series in pagerduty notification #8479, thx @rickymoorhouse
  • Timezone: Time ranges like Today & Yesterday now work correctly when timezone setting is set to UTC #8916, thx @ctide
  • Prometheus: Align $__interval with the step parameters. #9226, thx @alin-amana
  • Prometheus: Autocomplete for label name and label value #9208, thx @mtanda
  • Postgres: New Postgres data source #9209, thx @svenklemm
  • Datasources: closes #9371, #5334, #8812, thx @mattbostock

Minor Changes

  • SMTP: Make it possible to set specific EHLO for smtp client. #9319
  • Dataproxy: Allow grafan to renegotiate tls connection #9250
  • HTTP: set net.Dialer.DualStack to true for all http clients #9367
  • Alerting: Add diff and percent diff as series reducers #9386, thx @shanhuhai5739
  • Slack: Allow images to be uploaded to slack when Token is precent #7175, thx @xginn8
  • Opsgenie: Use their latest API instead of old version #9399, thx @cglrkn
  • Table: Add support for displaying the timestamp with milliseconds #9429, thx @s1061123
  • Hipchat: Add metrics, message and image to hipchat notifications #9110, thx @eloo

Tech

  • Go: Grafana is now built using golang 1.9

#2

Good stuff! But looks like InfluxDB is starting to lag behind :frowning:


#3

We’re using the latest Docker version of Grafana - 4.6.0-beta-2, and it seems the new annotations feature doesn’t work?
We’re trying to press Ctrl+Click on graphs, and on marked areas of the graph - both in the dashboard, and when we’re looking at a single graph - nothing seems to happen.
Is there any additional configuration needed for existing dashboards?
Maybe the beta version doesn’t include this feature yet?


#4

If your on MAC try CMD+click


#5

Doesn’t work either… Tried both a Mac and a Linux, both Chrome and Firefox.
Is there a demo Grafana dashboard where I can try this?


#6

You have to be logged in for it to work. Just had the exact same experience and thought we had broken the build but the feature requires a signed in user to work.


#7

Nope, it’s something else… I’m signed in as an admin…


#8

The latest beta is up on the play.grafana.org site but visitors do not have write access so you can’t test there unfortunately.

Maybe you could do a quick test with Docker? I just ran this:

docker run -d --name=grafana46beta3 -p 3003:3000 grafana/grafana:4.6.0-beta3

Logged in as admin (on localhost:3003), created a dashboard and created an annotation using ctrl+click. Tested with both Chrome and Firefox on Ubuntu.

Any more info you can provide to help troubleshoot this?


#9

Works when I run locally…
Could be HTTPS is the issue(??)
Maybe something in the configuration is different?


#10

Interesting, I’m still getting served the .js file of an older version of Grafana, even though the login screen shows the new version.


#11

Solved.
Apparently the way I installed plugins in docker was definitely not the way to go.
Found out there’s a parameter for that since version 3.
Thanks!!! Amazing feature!


#12

Awesome job guys :smile:


#13

@torkel
First of all, thanks new awesome features! :slight_smile:
I’ve been playing around a bit and noticed that read-only editors can’t create custom annotations. According to their permissions (can edit panels and create new panels), maybe it would be reasonable to add a possibility to create custom annotations for read-only editors. What do you think about that?


#14

What about Grafana cloud? Is Grafana cloud 4.6 yet? I don’t see any new 4.6 features added on Grafana cloud yet.


#15

Yes, some GrafanaCloud instances are on 4.6 - it is gradually being rolled out. You can check the version of your instance by navigating to a settings page (the Profile page for example) and the version number is in the page footer:

image

If you are not on 4.6, you can kickstart the upgrade by installing or updating a plugin via Grafana.com. This will cause the server to restart.


#16

Hello,

How to get 4.6.1 source code?  i got the source code is 4.7 from github by "go get github.com/grafana/grafana"

Thanks!


#17

The master branch will become the 4.7 release in the near future. If you want the 4.6.1 code specifically then with git you can checkout the tag for 4.6.1.

git checkout v4.6.1


#18

missing release notes for v4.6.2


#19

Added the release notes for 4.6.2 now.


#20

What’s the location for default plugins like graph, singlestat in 4.6.3-1? Can’t find those in /var/lib/grafana/plugins.
Directly copying a custom plugin from 4.4 breaks the plugin as import statements fail.

The custom plugin documentation still has old documentation with the old paths.