grafana: 6.3.6
mysql: 5.7.28 MySQL Community Server
OS: Red Hat 6.7
hello! My grafana and MySQL are installed on the same virtual machine with different ports. When I use chrome on my PC(win 10) to visit the ip:port of grafana and configure the mysql datasource, I can save and test the configuration. However, when I configure panel using the datasourse of mysql, it won’t show recommend tables or columns. Certainly, it could not show any no data point. And the browser show “POST http://xxxxxxxx:3000/api/tsdb/query net::ERR_CONNECTION_RESET”. I have tried localhost:3306, and ip:3306 and got the same result. In addition, I can use my win 10 PC to connect mysql remotely and my another grafana on another virtual machine could configure and show data of mysql normally.

Are there any errors in the Grafana server logs? If they are on the same machine then Grafana should be able to access the MySQL database.

No, there are no error in the Grafana server logs. And I found that if I visit my Grafana in the Intranet environment, I could configure the panel using MySQL datasource and it could show data of MySQL normally. If I visit my Grafana in the extranet environment, it doesn’t work. But I can visit Grafana using other datasourse and connect mysql remotely in the extranet environment. I wonder if any firewall policy result in this…

This sounds like a networking problem and checking your firewall settings would be a good first step.