Multidimensional rule cannot be created with mssql datasource

  • What Grafana version and what operating system are you using?
    grafana v8.3.4 on Red Hat Enterprise Linux release 8.3

  • What are you trying to achieve?
    create a multidimensional rule for an alert using the unified alert system, so every time a different series goes over the limit, a new alert is raised.
    At this point, I have 8 series, 4 of them over the limit and the other 4 under the limit. Using the classic condition, an alert is raised as at least one of the series is over the limit, but it won’t raise a new alert unless all series recover again.

  • How are you trying to achieve it?
    Creating the SQL query and using the math condition to evaluate all series

  • What happened?
    An error is raised:
    “invalid format of evaluation results for the alert definition : frame cannot uniquely be identified by its labels: has duplicate results with labels {}”

  • What did you expect to happen?
    I expected that the labels from the math conditions be similar to the ones in the sql query, instead of being B for all queries (I don’t know if the problem comes from here), and then, the alert is raised for all series that are over the limit.

On the opposite way, if I configure for classic condition, it raises the single alert, but the label is empty inside the response for all series, I don’t know if having the label empty on classic condition is related to the error using the multidimensional rule:


  • Can you copy/paste the configuration(s) that you are having problems with?

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

  • Did you follow any online instructions? If so, what is the URL?
    I tried to follow the instruction to create a multidimensional rule:
    Create Grafana managed alert rule | Grafana documentation

I tried creating an intermediate reduce expression, but the same error is raised:

The problem seems to be the metric column, if it has any other name, it works fine.
I’ve created a bug ticket:

1 Like