Manually adding Adaptive Metrics rules?

I can’t find any way to add aggregation rule in Adaptive Metrics manually. Is it really only built on top of the recommended rules? I had one recommended rule, I applied it, it worked, then it said I had new recommendations, I tried to apply them and working rule is now gone. I’d like to have it back, but I can’t seem to be able to do it manually and it’s not being recommended again.

Hello lalinsky, I’m Pauric, product designer for Adaptive Telemetry (inc Adaptive Metrics). While it is not currently possible to modify or create rules in the web interface, you can do via API

With that said, “Adaptive” is the keyword here. We want to get you to a place where you trust the engine to do its business and understand that rules can be: new, updated and even removed to achieve optimal results. It’s possible that the net result of removing that original rule was a decrease is overal active series or, there were changes in your environment requiring the rule to be removed.

I’d like to understand what you saw in the initial results for the first rule you set and the subsequent effect of the new recommendations? I acknowledge we have some ways to go to better communicate the effect and reasons for recommended changes, your input on what we could have done to better communicate our recommendations is greatly appreciated.

1 Like

Here is what happened:

  • I enabled metrics, created some dashboards and one day later, I had a good recommendation from the Adaptive Metrics, I applied it and it worked.
  • A few days later, I went to Adaptive Metrics, I’ve only seen the existing applied recommendation, but there was a banner on the top of the page, saying that there are new recommendations and if I want to apply them. I didn’t see any new recommendations, but the banner kept showing.
  • So I decided to click “Apply recommendations” on the banner and after that, the active recommendation was removed. I was thinking it’s some kind of glitch, so I waited a few days.
  • The previously active recommendation is still not there and neither is there a new recommendation with the previous rules.

I really wanted to try using it as “adaptive”, not get involved manually, but seeing that it failed me within the trial period, I’m not sure if I can trust it.

I’ll have a look at the API to see if I can manage aggregations like that. Failing that, I guess I’ll have to deploy some kind of aggregation layer (like VictoriaMetrics agent) in front of grafana-agent to already send pre-aggregated metrics.

Something is amiss here and I will take these steps to the team for further discussion.

Clarification question. Are you 100% you saw an ‘apply recommendations’ on the notification banner? it should have looked something like this with a [review recommendations] button.

And when you click the review button it takes you to the recommendations tab, the blue [apply recommendations] button should not be enabled if there are no rules to apply.

Further question, did you see a confirmation dialog similar to this one after you pressed Apply Recommendations and if so do you recall any details?

1 Like

I’m not sure about the exact wording, but the banner looked just like the blue one you posted. I think it had something with “apply” in the button instead of “review recommended rules”, but I’m not 100% sure now. And I didn’t get the second pop up dialog with the overview.

I suspect what may have happened is you hit the banner button and the apply button on the recommendations tab appeared in roughly the same space. I think the details around this are moot, the fact you were able to press an apply button at all when there are no recommendations would be a bug, where you did not see a confirmation dialog would also be a bug. I have not been able to reproduce this. Are you seeing the same behaviour? could you record it for us if possible and it doesn’t disclose sensitive information. That would be greatly appreciated too.

Thank you again for the feedback and please reach out to me if you have other challenges with the UI.

If I see the banner again, I’ll record my screen to show you. For now, I have no new recommendations, no banner. That’s why I wanted to find out about the manual entry, because I’d really like the aggregations to be applied. :slight_smile:

Interesting, do you see any rules on the applied page?

No, it’s all empty.

Ok, your environment is now in a state where the engine cant find optimisation (e.g. fewer than 99 active series reduction). If/when it does detect something, reach back out to me. Sorry about this, hope you can get to a point where you see the savings intended.

If it’s of any use, it could be also related to me upgrading from the Trial to Pro plan. I did this soon after upgrading my plan and I see constant problems with usage metrics since the upgrade. For example, this how my home page looks after the upgrade (note that I’m on the Pro plan, not Trial and I have active metrics and logs):