loki is consuming more space even for small logs.

Hi, I am new to loki ,
when the application started promtail send the logs to loki and the loki is consuming more space with in a day it consuming more space. when chunks reach 100gb loki is stopped. (I am running the promtail in three servers. )
Any suggestions please ?.
loki config.
auth_enabled: false

server:
http_listen_port: 3100
grpc_listen_port: 9096

ingester:
wal:
enabled: true
dir: /var/loki/wal
lifecycler:
address: 127.0.0.1
ring:
kvstore:
store: inmemory
replication_factor: 1
final_sleep: 0s
chunk_idle_period: 3m # Any chunk not receiving new logs in this time will be flushed
chunk_target_size: 1572864 # Loki will attempt to build chunks up to 1.5MB, flushing first if chunk_idle_period or max_chunk_age is reached first
chunk_encoding: gzip
chunk_retain_period: 1m # Must be greater than index read cache TTL if using an index cache (Default index read cache TTL is 5m)
max_transfer_retries: 0 # Chunk transfers disabled

schema_config:
configs:

  • from: 2021-12-22
    store: boltdb-shipper
    object_store: filesystem
    schema: v11
    index:
    prefix: index_
    period: 24h

storage_config:
boltdb_shipper:
active_index_directory: /var/loki/boltdb-shipper-active
cache_location: /var/loki/boltdb-shipper-cache
cache_ttl: 24h # Can be increased for faster performance over longer query periods, uses more disk space
shared_store: filesystem
filesystem:
directory: /var/loki/chunks
compactor:
working_directory: /var/loki/boltdb-shipper-compactor
shared_store: filesystem
retention_enabled: true
retention_delete_delay: 2h
retention_delete_worker_count: 150
limits_config:
enforce_metric_name: false
reject_old_samples: true
reject_old_samples_max_age: 168h
ingestion_rate_mb: 8
retention_period: 48h

chunk_store_config:
max_look_back_period: 0s

table_manager:
retention_deletes_enabled: false
retention_period: 72h

ruler:
storage:
type: local
local:
directory: /var/loki/rules
rule_path: /var/loki/rules-temp
alertmanager_url: ****************
ring:
kvstore:
store: inmemory
enable_api: true