Loki , fluentd , fluent-bit compatible versions

Hi All
At present, we are using the below components for our logging solution and respective helm chart versions.
loki - 2.16.0.
fluentd - 5.4.1
fluent-bit - 0.20.8

If we want to upgrade the loki to higher versions , we want to know the compatible versions of the remaining two components - fluentd and fluent-bit

Can anyone provide me the compatible versions of fluentd and fluent-bit for the appropriate loki versions.

I dont know if Loki provides an official compatibility map. I would say, however, that the APIs for Loki generally haven’t changed all that much, and I suspect if you bring all three components to the latest version you would be just fine.

Test it out first, of course.