Issue when building v6.7.x on Windows10 using Edge Browser

I am trying to build Grafana v6.7.4 from source on Windows. To do this I have been following the instructions posted on this site. Here are the steps I have taken to get to where I am (these are all run in an msys/mingw environment) :

  1. Download and install Go 1.13.14
  2. Download and install node 12.17.0
  3. In the Go structure I clone grafana and checkout v6.7.4
  4. From the source directory run “go run build.go setup”
  5. Run “go run build.go build”
  6. Install yarn “npm install -g yarn”. This installs version 1.22.4
  7. Run “yarn install --pure-lockfile”, I have also tried --frozen-lockfile
  8. Run “yarn build”

All of this runs successfully with no errors. I think launch grafana from the bin\windows-amd64 directory using where I set the ini to use, the homepath, and the paths to provisions, logs, data and plugins. This is where things go off the rails. I get the generic:

"If you’re seeing this Grafana has failed to loads its application files

  1. This could be caused by your reverse proxy settings
  2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath
  3. If you have a local dev build make sure you build frontend using: yarn start, yarn start:hot, or yarn build
  4. Sometimes restarting grafana-server can help"

To debug this further I have downloaded the 6.7.4 windows release and just replaced the build and views directories in the grafana/public directory where I compiled. I then run my exact same command to launch grafana using my compiled back end and everything is happy. I also went all the way back until the build worked for me and was able to get a fully working build by following the exact instructions above and using the v6.6.2 tag. So unless the instructions have changed between v6.6.2 and v6.7.4 I believe I am following the correct process. Everything is being run using localhost and I am not trying to do anything outside of my environment.

After scouring the community here I found that it may be specific to the Edge browser with my “broken” environment so I installed both Firefox and Chrome and they are working fine. This confuses me even further and would like my resulting content to work on all browsers.

I would like to be able to develop on the newer baseline, but I am unable to test anything on the Edge browser in my Windows 10 VM.

I have done these exact same steps on a Centos7 machine and it generates a functional environment, but of course I did not test this with the Edge browser.

I have also run all of the front end and back end tests per the instructions I found on the grafana site, and I only get a couple of failures out of the lot and they do not appear to be related to this issue I am seeing. There are also 0 errors being reported on the console and nothing in the generated grafana.log file.

Any help I could get on this would be great, and if you need any further information or would like me to test anything else out I am more than happy to do so.


Just as another point of note, I did a full rebuild using the v7.1.1 of the front-end and the same issue exists whenever I am using the Edge browser, and I also see this issue on my Firefox browser as well now after updating to this tag.

Thank you again for any assistance.

Just another update as I had gotten pulled into other work and just had a chance to come back to this. I am now building with v7.1.5 and I still have the same issue. I was hoping that whatever is causing this issue would be resolved, but it is not and it fails on all browsers with this release.
After doing a complete search and replace of the generated .js and .map files multiple times to determine which ones are causing the issue I have determined that if you replace and modify the hash for the 3 pairs of generated .map and .js files below:


Then I am able to load everything in my browsers. Not sure if this provides any more clues or not.
I have also updated to Go 1.14.9, yarn 1.22.5 and node v12.18.3 to see if that would help, which it did not.
I also updated browserslist using “npx browserslist@latest --update-db” to get rid of the three “caniuse-list outdated” warnings to see if that was causing an issue and experience the same behavior.
Any help debugging this would be greatly appreciated.