Installing grafana/graphite on raspberry pi

  • What Grafana version and what operating system are you using?

Grafana 9.4.7
Graphite 1.1.3-6
Raspberry pi 2023-02-21

  • What are you trying to achieve?

Connect grafana to a graphite data source

  • How are you trying to achieve it?

From the dashboard

  • What happened?

My graphite instance is running on graphite.local on port 80 (well, nginx fronting it). When I set the graphite datasource URL to ‘http://graphite.local/’ and hit “Save and test”, it comes back with

<!doctype html> <html lang=en> <title>415 Unsupported Media Type</title> <h1>Unsupported Media Type</h1> <p>Did not attempt to load JSON data because the request Content-Type was not &#39;application/json&#39;.</p>

Also, when I look in the grafana logs, this is what I see:

logger=cleanup t=2023-04-27T00:08:43.548841837+01:00 level=info msg="Completed cleanup jobs" duration=38.444037ms
logger=context userId=1 orgId=1 uname=admin t=2023-04-27T00:08:47.612348259+01:00 level=info msg="Request Completed" method=POST path=/api/datasources/proxy/uid/pXD6pis4z/render status=415 remote_addr= time_ms=210 duration=210.381553ms size=215 referer=http://grafana.local:3000/datasources/edit/pXD6pis4z handler=/api/datasources/proxy/uid/:uid/*

I don’t see any mention of it trying to reach http://graphite.local. I also don’t see the datasource file showing up in /etc/grafana/provisioning/datasources

  • What did you expect to happen?

I suppose I was expecting either for it to work, or to have some sort of error which I could troubleshoot.

  • Can you copy/paste the configuration(s) that you are having problems with?

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

See above

  • Did you follow any online instructions? If so, what is the URL?

that error is a red herring the issue is elsewhere. for example let us say I have a POST rest api that expects one of the parameter [FromBody] DataInput and I made a call to this endpoint but omit DataInput you will get the same error

415 Unsupported Media Type</title> <h1>Unsupported Media Type<

what if you just used the following

spun up graphite using podman, fed it some data via python

You’re right. The problem is that I had set up graphite-api, and the plugin was expecting graphite-web (although it would be nice if it said as much somewhere, given that there are two different ways of setting up graphite).

Anyway, I’ve given up on graphite, I installed prometheus instead, and it all just worked!

Thanks for the response, though!


1 Like