How to renew the SSL Certificate in Grafana 5.3 V

Hi Team,

I need help on renewing SSL Certificate. I have generated the csr & key and having pem certificate. Tried to upload the CSR , KEY & PEM file in etc/grafana path and updated the grafana.ini file with latest key & PEM File. Still SSL certificate is showing the old certificate details. After restarting the server got “TLS handshake error from” and loaded shows disabled. What would be the isssue?

Loaded: loaded (/usr/lib/systemd/system/grafana-server.service; disabled; vendor preset: disabled)
Active: active (running) since Mon 2020-06-xx 08:35:24 CDT; xx days ago
Main PID: xxxx(grafana-server)

Can somebody please assist on how to get this fixed?


I would carefully check the ownership and permissions of the files you’ve

Also, what does /var/log/grafana/grafana.log tell you when you try to restart?


Thanks for your reply Antony,
I tried it on 1st July. Later checking today.
\I can see below log in /var path.

t=2020-07-06T06:35:20-0500 lvl=info msg=“Request Completed” logger=context userId=0 orgId=0 uname= method=GET path=/ status=302 size=29

=eror msg=“Server shutdown” logger=server reason=“tls: private key does not match public key”

I got the above error when i update the certificate key & pem in etc/grafana path and also unable to restart the grafana server.

@pooh - Do i have any suggestion on this request?

Well, all I can say is that the error message is telling you that the private
key (in the key file) does not match the public key (in the certificate).

I would check very carefully that:

a) you have obtained a matching certificate & key from your CA

b) you have correctly copied the key file supplied by the CA to your Grafana

c) you have correctly copied the certificate supplied by the CA to your Grafana

d) you do not have any old certificate or key files remaining on your Grafana

e) you have restarted Grafana after checking all the above.