How to find grafana.ini file in Docker container?

Hello to all!

I have installed Grafana and InfluxDB on my Synology NAS via Docker. Installed via the GUI of Synology. Everything is working fine.
I now want to add alerting via email in Grafana and to configure that I need to edit the grafana.ini file.
The problem is that I don’t know how to “enter” into the grafana configuration files, as it’s installed as container.
I know how to enter via SSH to my Synology, tried to search the folders, but not much luck.
Can someone help me out?

Regards!

Hi,

Just run with ssh :

docker ps

→ Get your container $name

Then :

docker exec –it $name /bin/bash

You will get inside your grafana server.

Hope it helps.

Good Luck

Woah! Thank you @wlargou , that worked, had to cd back to the “root” directory for /etc, but figured it out, cheers!
P.S. That was more a Docker related question, rather than Grafana, sorry…

3 Likes

Hi, I have a similar problem. I can’t find an ini file on Grafana configuration. According to your instructions, I will join the Docker, but I can’t get to the CONF directory. There are many folders in the bin directory, but properly on the configuration. Can you help you find an ini file for Grafana


?

1 Like

Hi,

Followed your instructions, but the grafana.ini file is “Read Only” and I am sitting with “bash: sudo: command not found”. Did you have the same issue?

Hi,

Did you try :

find / -name grafana.ini

Also please check inside /etc that’s where it is supposed to be.

Hope it helps.

Good Luck

1 Like

Hy nothing

Tnx Where to find grafana.ini on docker installation? - Solutions - openHAB Community

This topic was automatically closed after 365 days. New replies are no longer allowed.