How to disable oncall integration heartbeat

Hi all,
We have enabled a heartbeat check on one of our oncall webhook integrations in Grafana cloud.
We would however like to stop using this feature for that specific webhook but I do not seem to find a way to remove the heartbeat check. Does anybody have an idea on how to get rid of the persisting heartbeat error now we no longer send heartbeats?


You can delete both integrations and outgoing webhooks but going to their respective tab, and finding the 3 dots next to their line and select “delete”

There’s no option to disable the heartbeat on the integration, though it only results in a red icon next to the integration name and doesn’t impact how integration works. I’ve added a bug Unable to Disable Heartbeat · Issue #3956 · grafana/oncall · GitHub to track this issue

1 Like