Hiding "0" values in elasticsearch graph panel results


Is there a way to hide 0’s in graphs with elasticsearch as the data source? This is an example that shows a thick yellow line of overlapping point markers on the x-axis for all time buckets with a count of 0.

When I make similar graphs with other datasources, they automatically hide those 0’s.


I can work around this by setting the Y-axis min to a low number like 0.01, but maybe there is an option somewhere that I did not see?



You can find a setting under the labels tab for hiding series having only zeros.


Thanks for responding. I did not see a labels tab, but I tried selecting the options under “legend” to hide series with only zeros or nulls, but it did not work maybe since there are some non-zero points

Yeah meant legend tab. Okay I understand your problem.

Maybe you can add a filter then to your query to not include values above 0?


Hi, I’m having the same issue (just starting out with influxdb and grafana v5.4.3) .
Could you give me any hints on how to modify this query to only include values above 0?

SELECT count("value") AS "SUCCESS" FROM "build_result" WHERE ("value" = 'SUCCESS') AND $timeFilter GROUP BY time($__interval) fill(null)

It looks like InfluxDB does not support having count(value) > 0.

There’s an open feature request for InfluxDB to support having, see https://github.com/influxdata/influxdb/issues/5266

1 Like