Hide time column in grafana bar gauge

How can I hide the time column, when show 0 values in bar gauge panel. I am using multiple frames in one panel. I cannot use transformations since it has multiple frames in one panel. Please help me to resolve this issue. I am using grafana 8.1.1.

Hi @lochanie1987

You should be able to do this using the value options inside the panel editor. I see you’re using mysql however so it’s also possible that your time field is not getting automatically hidden on the bar guage, which it often does.

Can you share your raw unformatted data, or what your query returns as viewed in the table visualization? Then we can mock up your data and tell you just how to fix this.

But fiddle with the panel editor and especially this:

@ mattabrams,
Hi mattabrams,
Thank you so much for your response. But when we select all values option. If there is data in one frame it shows only the value. Name is not shown. This is how I write queries in panel.

This is how it shows when I select all_values option:

This is the table view.

I want to keep the names and value as 0. when there is no data.
Thanks in advanced.

Hi @lochanie1987

It looks like you need to merge your two series into one. In other words, you see how your data is spread across two tables? Try to get it all on one table using the merge transformation: