Grafana Datasource - Sign a Private Plugin


I have one query with respect to Siging a private plugin

Currently we are trying to sign a private plugin by following the below steps from the this link Grafana Panel - Sign a Private Plugin - #7 by mikhailvolkov, however we are encountering an error at the time of sign please suggest.

I am running localhost on 4000 port

1 Like

Do you need the signatureType parameter?

Yes, maybe not needed but without that flag also same error persists. Actually, we tried the same instruction as mentioned in the above official link first, still its showing the same error, that is why we added this flag to see if this makes any difference, but it doesn’t.

Could you please suggest why this error is occurring if you have come across such?

1 Like

Hello All, I have tried the private plugin sign commands on different machine (on Linux) and the error is new this time could anyone please suggest.

where should we place the privately signed plugin in Grafana folder structure ? @yosiasz if you are aware please suggest.

Where all plugins go,under data/plugin folder :open_file_folder:

Hello @yosiasz getting this error,

“Skipping loading plugin due to problem with signature” after using signed plugin

could you please suggest to resolve this error?