Grafana can’t see ES indexes?

Hi all!

Just started using Grafana + ES. I run ES in docker:

docker run -d --name es -p 9200:9200 -p 9300:9300 -e “discovery.type=single-node”

Then generated some data into index recipes that look like these:

“hits”: [
“_index”: “recipes”,
“_type”: “salads”,
“_id”: “8d_JKHIBzym3yKfai79o”,
“_score”: 1,
“_source”: {
“title”: “-”,
“submitter”: “-”,
“description”: “-”,
“calories”: 0,
“ingredients”: ,
“timestamp”: 1589822195829


Then I registered created ES cluster in Grafana:

“datasource”: {
“id”: 4,
“orgId”: 1,
“name”: “Elasticsearch”,
“type”: “elasticsearch”,
“typeLogoUrl”: “”,
“access”: “direct”,
“url”: “http://localhost:9200”,
“password”: “”,
“user”: “”,
“database”: “recipes”,
“basicAuth”: false,
“basicAuthUser”: “”,
“basicAuthPassword”: “”,
“withCredentials”: false,
“isDefault”: true,
“jsonData”: {
“esVersion”: 77,
“logLevelField”: “”,
“logMessageField”: “”,
“maxConcurrentShardRequests”: 256,
“timeField”: “timestamp”
“secureJsonFields”: {},
“version”: 25,
“readOnly”: false
“id”: 4,
“message”: “Datasource updated”,
“name”: “Elasticsearch”

Started a panel. After that I expected to see data that were in recipe index but I didn’t.
They must appear in panel, right?

In Chrome dev tools console I see only OPTION http requests:

I’m trying to work out this issue all day long and this upsets me.

Am I doing something wrong?


First off make sure you have the correct time-scope selected in grafana.
Second, validate that your elasticsearch entry is correctly indexed with a timestamp within that period.

When you add your datasource in grafana, make sure you get the “Index OK. Time field name OK.” message. This means grafana can actually access and query elasticsearch.

I made an example project to test this setup:

You will manually have to add the datasource and the dashboard.
1 Like

Thank you so much) That helped me a lot!