Grafana 9 origin not allowed

I just made an update from grafana 8 to grafana 9 on two servers (staging ,production)
On staging machine access is via ip and not domain ,http protocol , everything working correct.

On production i don’t have nginx or apache ,using azure application gateway .
In app gateway i do have redirect from http to https.
before the upgrade everything worked fine with same app-gateway config .
Now i have origin not allowed errors when trying to add any elasticsearch connector , and have the same error even when entering into my main page .

i saw solutions for apache and nginx with proxy_set_header Host $http_host; but i dont have this option on app-gateway

Issue solved :
The solution was to specify the domain name on “Override with specific domain name” option on application gateway backend pool settings .

I tried it is not working , if possible can you please share your application gateway settings

The below config update has worked for me

For those working on k8s + ingress set in grafana.ini
csrf_additional_headers: “”
csrf_trusted_origins: “<extarnal_domain>”