Grafana 7 and traefik v1.7/2.0 randomly 404 errors

Hello guys,
I have been using Grafana 6 and traefik v1.7 in docker containers for quite some time without issue.
I decided to start playing with Gafana7 and runs ok when I get connected in the local network and also using port forwarding on my router and the ISP IP.

I decided to migrate my docker container traefik 1.7 to traefik2.0 and it worked but random errors 404 appears sometime when dashboard refresh as you can see on the windows capture, I though that the problem was Traefik v2 , but now I tried Grafana 7 with my traefik1.7 container and I got the same issue… 404 errors page not found… Grafana 6 do not that kind of issue with traefik1.7
The thing is I am not sure how to troubleshoot this any further, I don’t see any error on the Traefik v2.0 container and no error on the Grafana containers log
What I see is Grafana7 is having some miss understanding with Traefik V1.7 and V2.0…?
What could be happening ?

I think I found the cause of my problem with Traefik and Grafana, nothing to do with Traefik…
it was Grafana container that was restarting every 15 to 20 seconds… I think I put some crap inside the container that make it to crash.