Force compressions

I have a loki configured as follows:

        {
          "auth_enabled": false,
          "chunk_store_config": {
            "max_look_back_period": "744h"
          },
          "compactor": {
            "compactor_ring": {
              "kvstore": {
                "store": "inmemory"
              }
            },
            "shared_store": "filesystem",
            "working_directory": "${baseDir}"
          },
          "ingester": {
            "chunk_idle_period": "1h",
            "chunk_retain_period": "30s",
            "chunk_target_size": 999999,
            "lifecycler": {
              "address": "127.0.0.1",
              "ring": {
                "kvstore": {
                  "store": "inmemory"
                },
                "replication_factor": 1
              }
            },
            "max_chunk_age": "1h",
            "max_transfer_retries": 0
          },
          "limits_config": {
            "reject_old_samples": true,
            "reject_old_samples_max_age": "168h",
            "retention_period": "744h"
          },
          "schema_config": {
            "configs": [
              {
                "from": "2022-06-06",
                "index": {
                  "period": "24h",
                  "prefix": "index_"
                },
                "object_store": "filesystem",
                "schema": "v11",
                "store": "boltdb-shipper"
              }
            ]
          },
          "server": {
            "http_listen_port": 3030,
            "log_level": "warn"
          },
          "storage_config": {
            "boltdb_shipper": {
              "active_index_directory": "${baseDir}/boltdb-shipper-active",
              "cache_location": "${baseDir}/boltdb-shipper-cache",
              "cache_ttl": "24h",
              "shared_store": "filesystem"
            },
            "filesystem": {
              "directory": "${baseDir}/chunks"
            }
          },
          "table_manager": {
            "retention_deletes_enabled": true,
            "retention_period": "744h"
          },
          "ruler": {
            "enable_api": true,
            "enable_alertmanager_v2": true,
            "ring": {
              "kvstore": {
                "store": "inmemory"
              }
            },
            "rule_path": "/var/lib/loki/rules-temp",
            "alertmanager_url": "http://127.0.0.1:3041",
            "storage": {
              "type": "local",
              "local": {
                "directory": "${baseDir}/rules"
              }
            }
          }
        }

However, I still have chunks from September.

I have tried:

curl -g -XPOST 'http://localhost:3030/v1/delete?end=1704063600'

but I have got a 404.

Anything wrong in my configuration?

Thanks in advance for your help,
Regards.

You need to pick one between table manager and compactor. For the newer version compactor is recommended, so you’ll want to disable table manager. See Retention | Grafana Loki documentation.

Thanks for your answer, I have dropped the table_manager but it did not have any effect, should I change anything else to change?

It took a bit of time, but it worked!
Thanks.