Fails to open k6 web dashboard, please do me a favor, thanks

I installed k6 0.49.0 version, there is a new feature: web dashboard.
After running scripts, I open (http://127.0.0.1:5665/)
Below error pops

from the picture, we can see that the inbound rules are correct.

Are there any other configurations I need to check?

Hi @brendaat , welcome to the community forum!

I don’t think that firewall configuration is needed for accessing localhost.
Do you start k6 with the --out 'web-dashboard' command line option? It enables the web-dashboard.

Does your k6 start like this? (web-dashboard url appears on the console)

> k6 run --out 'web-dashboard' script.js                                                                                                                                 

          /\      |‾‾| /‾‾/   /‾‾/   
     /\  /  \     |  |/  /   /  /    
    /  \/    \    |     (   /   ‾‾\  
   /          \   |  |\  \ |  (‾)  | 
  / __________ \  |__| \__\ \_____/ .io

     execution: local
        script: script.js
 web dashboard: http://127.0.0.1:5665
        output: -

1 Like

I am on Windows, and this works for me. This was through some trial-and-error, using the method to supply options for k6/browser.

set “K6_WEB_DASHBOARD=true” && set “K6_WEB_DASHBOARD_PERIOD=5s” && k6 run --env [env variable] [path\to\script.js]

Then after the test has started, the dashboard can be viewed:
http://localhost:5665/ui/?endpoint=/

Kudos to the development team for an amazing feature, that is very appealing visually.

1 Like

Thanks @bandorko, @richmarshall , it works on my side. The main reason is that the web dashboard should be open when the k6 scripts are still running, if you open it after k6 runs, the problem will reproduce.
Anyway, thanks again for helping me with the issue, thanks.