Expected response data to be array, got undefined

I am a newbie, so just starting out in learning Grafana.
I have InfluxDB running, getting data from telegraf (which is sending data from the nodes it is running on). InfluxDB now has data in it in the telegraf database.

In Grafana I connected InfluxDB as a data source (the only one at this moment). It is running on the same host as Grafana and shows: “Data source is working” when tested.
URL is http://localhost:8086
Access is Browser (because when I set it to Server, I get Network Error: bad Gateway(502) when I test)

I have tried creating a simple panel to show one of the time series in the database.
The query looks like:
http://localhost:3000/query?u=admin&p=&db=telegraf&q=SELECT mean(“usage_system”) FROM “cpu” WHERE (“host” = ‘t1’ AND “cpu” = ‘cpu0’) AND $timeFilter GROUP BY time™ fill(null)&epoch=ms

There is a red exclamation point at the top of the Panel that when hovered over says: “Expected response data to be array, got undefined”

Does anyone know what is happening here, or how I can find out what is happening?

Thanks,
Cicada

I am seeing the same issue. Did you get any solution to this problem?

Not yet… am still hoping that someone will reply.

I have similar problem. Solution is to use http://IPaddress:8086 instead http://localhost:8086 as URL.

1 Like

About an hour ago we discovered this answer as well. I replaced localhost with 127.0.0.1 and it started working.

Hello I’m an amateur to influxdb grafana. I’ve got the same error as described above and the followed the same instructions by replacing localhost with 127.0.0.1 but I’m still seeing the same error on the dashboard panel.
Can someone please point me out if I’ve done any wrong configuration. TIA.

Is there a reason that you have specified port 3003?

Thanks for replying,

Yes,

  1. I followed this tutorial and there the port specified for grafana is the same.
    (https://hub.docker.com/r/philhawthorne/docker-influxdb-grafana/)

  2. This same port (3003) worked before for me. (Today when I checked suddenly my container was vanished and I had to setup everything from the scratch up to grafana, I don’t remember the whole configuration but I’m pretty sure the port before was also same and it worked perfectly.)

What have you got now for the URL for the influxdb datasource in grafana?

It would be interesting to know the answer to this question.

Thanks for the reply and the issue seems automatically solved now when I opened grafana today. I can now even see the old dashboards I created before my container got vanished (My container always had the same name). Seems like a network issue after all.

Adding to my previous reply:
Now the dashboard works even with http://localhost:3003