End to End testing

I am a total beginner w.r.t end to end testing.I want to know what setup do i need to do in order to perform e2e testing for my datasource plugin.I looked into the https://github.com/grafana/grafana/blob/master/contribute/style-guides/e2e.md but i was unable to figure out how to start.
My datasource plugin version is v6.7.3.(I cannot upgrade to v7.0 as v6.7.3 is about to be deployed)
Kind souls please help.

Hello @abhinandan13

Have you succeeded with first steps from e2e doc?

yarn e2e
yarn e2e:debug

If you got errors - please submit it here, community will be happy to help you :slight_smile:

V.

1 Like

huge thanks. a while ago i had a problem and never posted it.
will check it back and come with updates. thanks

Hello @vsergeyev,This is my current package.json file

{
  "name": "dummy-datasource",
  "version": "0.0.1",
  "description": "dummy Data Source",
  "scripts": {
    "build": "grafana-toolkit plugin:build",
    "test": "grafana-toolkit plugin:test",
    "dev": "grafana-toolkit plugin:dev",
    "watch": "grafana-toolkit plugin:dev --watch"
  },
  "author": "Dummy",
  "license": "Apache-2.0",
  "dependencies": {
    "@grafana/data": "^6.7.2",
    "@grafana/runtime": "^6.7.2",
    "@grafana/toolkit": "^6.7.2",
    "@grafana/ui": "^6.7.2",
    "notyf": "^3.7.0",
    "@typescript-eslint/eslint-plugin": "^3.0.2",
    "@typescript-eslint/parser": "^3.0.2",
    "eslint": "^7.1.0",
    "eslint-config-airbnb": "^18.1.0",
    "eslint-plugin-import": "^2.20.2",
    "eslint-plugin-jsx-a11y": "^6.2.3",
    "eslint-plugin-react": "^7.20.0",
    "eslint-plugin-react-hooks": "^4.0.4"
  },
  "devDependencies": {
    "ts-jest": "^26.1.0",
    "sass-loader": "^8.0.2",
    "ts-loader": "^7.0.5",
    "@types/enzyme": "^3.10.5",
    "@types/react-test-renderer": "^16.9.2",
    "@types/enzyme-adapter-react-16": "^1.0.5",
    "@types/lodash": "^4.14.150",
    "enzyme-adapter-react-16":"1.15.2"
  },
  "resolutions": {
    "@babel/preset-env": "7.9.0"
  }
}

Now when i run yarn e2e i get the following error

yarn run v1.22.4
error Command ā€œe2eā€ not found.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

I tried adding @grafana/e2e into my package using
yarn add @grafana/e2e

but got different error.
Any help would be appreciated :slightly_smiling_face: