Compatibility between Loki and Promtail

Hello,

Are there compatibility issues between different versions of Loki and Promtail?

I searched the documentation to find a kind of compatibility matrix but I couldn’t find anything.

The push API to Loki has remained stable for quite some time, I don’t know of any compatibility issues even going back to promtail < 1.0.0

However many improvements have been made to promtail over time and defaults have been adjusted etc so I would always recommend keeping it updated.