Can't find the "include images" checkbox for Alert images

I installed grafana-image-renderer, but I can’t enable the “include images” checkbox (it’s not visible in grafana).

I also checked the logs by referring to this URL (Slack alerts do not include image), but there seems to be no problem generating images.

The “Include images” checkbox is still nowhere to be found in my Grafana Contact points.
How can I send an image with the alarm?

I’ll answer for myself.

  1. Why there is no Include Image
    For Grafana 9.5 and later, simply add the following settings to your config file (e.g. grafana.ini).
    No need to look for the button.
    capture: true
  1. Why are images missing from Slack messages?
    Documentation: Use images in notifications | Grafana documentation
    This article had the answer.
    If it’s Upload from disk, need to use a slack bot token,
    If it’s from cloud storage (S3), need to use a Webhook.
    I used a webhook while using disk, which is why the message didn’t have an image attached.

This is now fixed.
I hope someone can refer to my post.

1 Like