Cannot parse json with "maxDuration" setup

Hello,

I’ve been trying to set “maxDuration” for my options scenarios, but I keep getting errors running k6

json: unknown field "maxDuration"

Here is my options

export const options = {
  insecureSkipTLSVerify: true,
  scenarios: {
    test_scenario: {
      executor: "constant-arrival-rate",
      timeUnit: "1s",
      preAllocatedVUs: 100,
      maxVUs: 16000,
      duration: "1m",
      rate: 100,
      exec: "GetRandom",
      startTime: "0m",
      maxDuration: "1m",
    },
  },
  summaryTrendStats: [
    "avg",
    "min",
    "med",
    "max",
    "p(90)",
    "p(95)",
    "p(99)",
    "count",
  ],
};

Hello @babydragon , welcome to the community forum!

There is no maxDuration option for the constant-arrival-rate executor. See the documentation: Constant arrival rate