Can not build from Source on Windows(10)

Heya,
I tried to reach some help from Slack but it seems my issue need more details, so I will make a thread here.
Before all I worked successfully on a v5.x version on grafana.
So now it’s time to update and running the new version.

I followed the documentation here: https://github.com/grafana/grafana/blob/master/contribute/developer-guide.md to get a fresh installation.
I updated Go:
PS D:\my-workspace\grafana> go version
go version go1.15.1 windows/amd64

I updated node:
PS D:\my-workspace\grafana> node -v
v12.18.3

I cloned the repository from github with the command clone.
I build successfully the front end with yarn command.

I installed make executable from http://gnuwin32.sourceforge.net/packages/make.htm
When I do my
make run
I got the error message:

PS D:\my-workspace\grafana> make run
File not found - *.sh
The system cannot find the path specified.
make: *** [scripts/go/bin/bra] Error 1

btw, my Grafana repository is not in my GOPATH folder.
Any idea ?
Thanks

hum, maybe the problem come from my GO environment.
When I do a ‘bra run’ or ‘mage -v’
after running go get -u github.com/grafana/grafana-plugin-sdk-go

I got the message

PS D:\my-workspace\grafana-7.1.5\data\plugins\my-ui-plugin> mage -v
mage : The term ‘mage’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of
the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1

  • mage -v
  •   + CategoryInfo          : ObjectNotFound: (mage:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException
    

Same for the bra command.
an idea ?

Thanks

PS: I’m the Original Poster

humm ok,
I can compile plugin after installing mage manually go get github.com/magefile/mage
And with the same thing I manually install bra with go get github.com/unknwon/bra and compile with

bra run

not the normal way but it works.