After configuring SMTP settings getting an error "SMTP not configured, check your grafana.ini config file's [smtp] section"

Hi guys, I am new to Grafana. This is my grafana.ini file.

check_for_updates = true
sigv4_auth_enabled = true
url =
mode = console
data = /var/lib/grafana/data
logs = /var/log/grafana
plugins = /var/lib/grafana/plugins
provisioning = /etc/grafana/provisioning
ehlo_identity =
enabled = true
from_address =
from_name = Grafana
host =
password = xxxx
skip_verify = true
user = xxxxx

But when I create a notification channel in Grafana and test it, I am getting an error saying SMTP not configured, check your grafana.ini config file’s [smtp] section Can anyone point out where I’m going wrong!?


You have a typo in the file :smile: , you should have

should be smtp

Hope it helps.

Good Luck

1 Like

Oh my god I was looking where everything went wrong almost 3 days :joy: , Thank you so much, you are a life saver

1 Like